OpenSUSE Tumbleweed : lecteurs NFS qui ne se montent plus après mise à jour

Après une mise à jour de mon système, mes lecteurs réseaux NFS (montés via autoFS), ne se montaient plus. Il était également impossible de les monter via les autres biais. J’obtenais un message d’erreur de type :

mount.nfs: Protocol not supported

Il semblerait qu’un fichier de configuration n’ai pas été mis à jour lors de la mise à jour de mes outils NFS. J’ai trouvé la solution sur ce thread, je ne suis pas le seul à avoir eu ce soucis ! Apparemment, ce fichier de configuration est considéré comme un fichier de configuration utilisateur (quand bien même vous n’ayez JAMAIS édité ce fichier manuellement), et l’installateur créé un fichier de configuration suffixé .rpmnew, et c’est à vous d’effectuer la fusion !

Dans le cas d’un fichier de configuration que vous n’aviez pas touché, cela consiste à supprimer le fichier d’origine (ou plus sagement le renommer en .old dans un premier temps et à le nettoyer par la suite) et à renommer le nouveau fichier avec le nom du fichier de configuration d’origine. Dans mon cas :

sudo mv /etc/nsswitch.conf /etc/nsswitch.conf.old
sudo mv /etc/nsswitch.conf.rpmnew /etc/nsswitch.conf

Après un reboot, tout refonctionne, ouf !

Cette logique est vraiment chiante !!!

Vous pouvez vérifier si vous avez d’autres fichiers dans ce cas via la commande rpmconfigcheck.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *